[Lights, Camera, Action]

Home    Forums    Tutorials    Search    Books    Links 

Windows Movie Maker tips, tutorials, forums and more...



 
Windows Movie Maker Home   Search   Login   Register   Member List  
Movie Maker Users Showcase  > Share Your XP Transitions and Effects!!  > my stuff    
Previous Thread :: Next Thread 
 Author Thread: my stuff
Ruzz is not online. Last active: 5/8/2004 11:47:23 AM Ruzz
Top 100 Poster
Joined: 20 Oct 2003
Total Posts: 11
 
my stuff
Posted: 16 Mar 2004 03:06 PM
apols to all those that had been asking for my stuff - been bizzie.

Anyway, dunno if all this is going to fit in one message, but they should appear in the next post.

Couple of things I should mention:

1 - save the content of the next message as "ruzz.xml" (or something-else.xml if you wish) and put it in the MM Addons folder eg
"...program files\movie maker\1033\AddOnTFX\ruzz.xml"

2 - I've yet to find any documentation for the various Control<n>Value PARAMs. Feel free to tinker with these (although, you should probably start your own xml file of add-ins so that you don't mess up my very cool originals). ;-)

3 - The RT-* in the name is just my initials - I wanted some way to know what I was looking at when the addons are listed. and... knowing it was *my* addon that screwed things up was good to know ;-)

OK... let's see if the cut-n-paste thing works...

Rz
Ruzz is not online. Last active: 5/8/2004 11:47:23 AM Ruzz
Top 100 Poster
Joined: 20 Oct 2003
Total Posts: 11
 
Re: my stuff
Posted: 16 Mar 2004 03:07 PM
<TransitionsAndEffects Version="1.0">
<Effects>
<EffectDLL guid="{E673DCF2-C316-4c6f-AA96-4E4DC6DC291E}" >

<Effect name="RT-Art-Graphic Pen" iconid="14" comment="Graphic Pen">
<Param name="EffectID" value="38" />
<Param name="Control1Value" value="15" />
<Param name="Control2Value" value="0" />
<Param name="Control3Value" value="40" />
<Param name="Transparency" value="40" />
</Effect>
<Effect name="RT-Art-Cartoon-C" iconid="14" comment="Cartoon Colour">
<Param name="EffectID" value="11" />
<Param name="Control1Value" value="25" />
</Effect>
<Effect name="RT-Art-Cartoon-BW" iconid="14" comment="Cartoon-BW">
<Param name="EffectID" value="18" />
<Param name="Control1Value" value="25" />
<Param name="Control1Value" value="25" />
<Param name="Control1Value" value="25" />
</Effect>
<Effect name="RT-Art-Cartoon-BW2" iconid="14" comment="Cartoon-BW2">
<Param name="EffectID" value="18" />
<Param name="Control1Value" value="25" />
<Param name="Control2Value" value="0" />
<Param name="Control3Value" value="25" />
</Effect>
<Effect name="RT-Art-Mat" iconid="14" comment="Mat">
<Param name="EffectID" value="18" />
<Param name="Control1Value" value="25" />
<Param name="Control2Value" value="5" />
<Param name="Control3Value" value="50" />
<Param name="Transparency" value="50" />
</Effect>
<Effect name="RT-Art-Mat2" iconid="14" comment="Mat2">
<Param name="EffectID" value="18" />
<Param name="Control1Value" value="25" />
<Param name="Control2Value" value="5" />
<Param name="Control3Value" value="50" />
<Param name="Transparency" value="25" />
</Effect>
<Effect name="RT-Art-InkOutline" iconid="14" comment="InkOutline">
<Param name="EffectID" value="17" />
<Param name="Control1Value" value="25" />
<Param name="Transparency" value="50" />
</Effect>
<Effect name="RT-Art-InkOutline2" iconid="14" comment="InkOutline2">
<Param name="EffectID" value="17" />
<Param name="Control1Value" value="25" />
</Effect>
<Effect name="RT-GlowingEdges" iconid="14" comment="GlowingEdges">
<Param name="EffectID" value="20" />
<Param name="Control1Value" value="5" />
<Param name="Control2Value" value="5" />
<Param name="Control3Value" value="5" />
<Param name="Transparency" value="60" />
</Effect>
<Effect name="RT-GlowingEdges2" iconid="14" comment="GlowingEdges2">
<Param name="EffectID" value="20" />
<Param name="Control1Value" value="50" />
<Param name="Control2Value" value="50" />
<Param name="Control3Value" value="50" />
<Param name="Transparency" value="80" />
</Effect>

</EffectDLL>

<EffectDLL guid="{7312498D-E87A-11D1-81E0-0000F87557DB}">
<Effect name="RT-Blur" iconid="30" comment="RT-Blur">
<Param name="PixelRadius" value="1.5" />
</Effect>
</EffectDLL>


<EffectDLL guid="{ADEADEB8-E54B-11d1-9A72-0000F875EADE}">
<Effect name="RT-Age-Jerky" iconid="4" comment="Film Age, Jerky">
<Param name="EdgeFade" value="100" />
<Param name="FilmJerkiness" value="255" />
<Param name="FlickerFrequency" value="250" />
<Param name="LineFrequency" value="200" />
<Param name="LintFrequency" value="150" />
<Param name="NoiseFrequency" value="50" />
<Param name="Greyscale" value="true" />
<Param name="PosterizeBits" value="2" />
</Effect>
<Effect name="RT-Age-Jerky2" iconid="4" comment="Film Age, Jerky 2">
<Param name="EdgeFade" value="50" />
<Param name="FilmJerkiness" value="255" />
<Param name="LineFrequency" value="200" />
<Param name="LintFrequency" value="200" />
<Param name="NoiseFrequency" value="150" />
<Param name="Greyscale" value="true" />
<Param name="PosterizeBits" value="3" />
</Effect>
<Effect name="RT-Foggy-Edges" iconid="4" comment="Film Age, Foggy Edges">
<Param name="EdgeFade" value="50" />
<Param name="Greyscale" value="true" />
<Param name="PosterizeBits" value="1" />
</Effect>
<Effect name="RT-Foggy-Edges2" iconid="4" comment="Film Age, Foggy Edges2">
<Param name="EdgeFade" value="150" />
<Param name="Greyscale" value="true" />
<Param name="PosterizeBits" value="3" />
</Effect>
<Effect name="RT-Foggy-Edges-x" iconid="4" comment="Film Age, Foggy Edges x">
<Param name="EdgeFade" value="100" />
<Param name="Greyscale" value="true" />
<Param name="PosterizeBits" value="8" />
</Effect>
</EffectDLL>




<EffectDLL guid="{B4DC8DD9-2CC1-4081-9B2B-20D7030234EF}">

<Effect name="RT-Colour-Negative" iconid="18" comment="Negative">
<Param name="InternalName" value="Standard" />
<Param name="Invert" value="-1.0" />
</Effect>
<Effect name="RT-Colour-Tint-Red" iconid="20" comment="TintRed">
<Param name="InternalName" value="Standard" />
<Param name="Desaturate" value="true" />
<Param name="Red" value="0.8" />
</Effect>
<Effect name="RT-Colour-Tint-Green" iconid="20" comment="TintGreen">
<Param name="InternalName" value="Standard" />
<Param name="Desaturate" value="true" />
<Param name="Green" value="0.8" />
</Effect>
<Effect name="RT-Colour-Tint-Blue" iconid="20" comment="TintBlue">
<Param name="InternalName" value="Standard" />
<Param name="Desaturate" value="true" />
<Param name="Blue" value="0.8" />
</Effect>
<Effect name="RT-Colour-Tint-Magenta" iconid="20" comment="TintMagenta">
<Param name="InternalName" value="Standard" />
<Param name="Desaturate" value="true" />
<Param name="Red" value="0.36" />
<Param name="Blue" value="0.36" />
</Effect>
<Effect name="RT-Colour-Tint-Sepia" iconid="20" comment="TintSepia">
<Param name="InternalName" value="Standard" />
<Param name="Desaturate" value="true" />
<Param name="Red" value="0.1" />
<Param name="Green" value="-0.36" />
<Param name="Blue" value="-0.96" />
</Effect>
<Effect name="RT-Colour-SuperContrast" iconid="20" comment="SuperContrast">
<Param name="InternalName" value="Standard" />
<Param name="Contrast" value="500.0" />
</Effect>


<Effect name="RT-Zoom-Inset" iconid="33" comment="Inset">
<Param name="InternalName" value="Simple3D" />
<Param name="InitialScaleA" value="1.2" />
<Param name="ScaleA" value="1.2" />
</Effect>
<Effect name="RT-Zoom-Inset-2" iconid="33" comment="Inset 2">
<Param name="InternalName" value="Simple3D" />
<Param name="InitialScaleA" value="1.5" />
<Param name="ScaleA" value="1.5" />
</Effect>
<Effect name="RT-Zoom-Outset" iconid="33" comment="Outset">
<Param name="InternalName" value="Simple3D" />
<Param name="InitialScaleA" value="0.8" />
<Param name="ScaleA" value="0.8" />
</Effect>
<Effect name="RT-Zoom-Outset-2" iconid="33" comment="Outset 2">
<Param name="InternalName" value="Simple3D" />
<Param name="InitialScaleA" value="0.5" />
<Param name="ScaleA" value="0.5" />
</Effect>
<Effect name="RT-Zoom-SetBack" iconid="33" comment="Set Back">
<Param name="InternalName" value="Simple3D" />
<Param name="InitialScaleA" value="1.0" />
<Param name="ScaleA" value="0.8" />
</Effect>
<Effect name="RT-Zoom-FastIn" iconid="33" comment="Fast In">
<Param name="InternalName" value="Simple3D" />
<Param name="ScaleA" value="3.0" />
<Param name="ExponentialProgressDuration" value="0.1" />
</Effect>
<Effect name="RT-Zoom-FastIn2" iconid="33" comment="Fast In2">
<Param name="InternalName" value="Simple3D" />
<Param name="ScaleA" value="5.0" />
<Param name="ExponentialProgressDuration" value="0.001" />
</Effect>
<Effect name="RT-Zoom-FastOut" iconid="33" comment="Fast Out">
<Param name="InternalName" value="Simple3D" />
<Param name="ScaleA" value="smaller" />
<Param name="ExponentialProgressDuration" value="0.1" />
</Effect>
<Effect name="RT-Zoom-FastOut2" iconid="33" comment="Fast Out2">
<Param name="InternalName" value="Simple3D" />
<Param name="ScaleA" value="smaller" />
<Param name="ExponentialProgressDuration" value="0.001" />
</Effect>

<Effect name="RT-Move-Left" iconid="33" comment="Move Left">
<Param name="InternalName" value="Simple3D" />
<Param name="MoveA" value="left" />
<Param name="MoveSpeedA" value="5000.O" />
<Param name="ExponentialProgressDuration" value="0.01" />
</Effect>

<Effect name="RT-Move-Right" iconid="33" comment="Move Right">
<Param name="InternalName" value="Simple3D" />
<Param name="MoveA" value="right" />
<Param name="MoveSpeedA" value="5000.O" />
<Param name="ExponentialProgressDuration" value="0.01" />
</Effect>
<Effect name="RT-Move-Up" iconid="33" comment="Move Up">
<Param name="InternalName" value="Simple3D" />
<Param name="MoveA" value="up" />
<Param name="MoveSpeedA" value="5.O" />
<Param name="ExponentialProgressDuration" value="1.0" />
</Effect>
</EffectDLL>
</Effects>

</TransitionsAndEffects>

Ruzz is not online. Last active: 5/8/2004 11:47:23 AM Ruzz
Top 100 Poster
Joined: 20 Oct 2003
Total Posts: 11
 
Re: my stuff
Posted: 16 Mar 2004 03:28 PM
Well, it seemed to work... except for some reason a couple of the zeros have changed to letter Os (my original file is fine - promise!)

Here's the few I spotted: (just paste them over the originals)

<Effect name="RT-Move-Left" iconid="33" comment="Move Left">
<Param name="InternalName" value="Simple3D" />
<Param name="MoveA" value="left" />
<Param name="MoveSpeedA" value="5000.0" />
<Param name="ExponentialProgressDuration" value="0.01" />
</Effect>
<Effect name="RT-Move-Right" iconid="33" comment="Move Right">
<Param name="InternalName" value="Simple3D" />
<Param name="MoveA" value="right" />
<Param name="MoveSpeedA" value="5000.0" />
<Param name="ExponentialProgressDuration" value="0.01" />
</Effect>
<Effect name="RT-Move-Up" iconid="33" comment="Move Up">
<Param name="InternalName" value="Simple3D" />
<Param name="MoveA" value="up" />
<Param name="MoveSpeedA" value="5.O" />
<Param name="ExponentialProgressDuration" value="1.0" />
</Effect>

That 5000.0 is probably "wrong" anyway - just me trying different things.

Rz
KJ is not online. Last active: 2/11/2005 8:06:37 PM KJ
Joined: 31 Aug 2003
Total Posts: 10
 
Re: my stuff
Posted: 16 Mar 2004 07:05 PM
Thanks Ruzz!!!

I've been waiting for these since this forum was created.
mr.selfdestruct is not online. Last active: 4/21/2004 2:00:08 PM mr.selfdestruct
Joined: 26 Dec 2003
Total Posts: 17
 
Re: my stuff
Posted: 16 Mar 2004 08:52 PM
ok i fixed the o to 0 problems you listed, saved this as "ruzz.xml" in the file path you gave, but its not showing up in the movie maker. =(

any ideas?
Ruzz is not online. Last active: 5/8/2004 11:47:23 AM Ruzz
Top 100 Poster
Joined: 20 Oct 2003
Total Posts: 11
 
Re: my stuff
Posted: 17 Mar 2004 01:49 AM
Probably a locale problem? Here are the instructions, straight from the horse's mouth.


Making Your Own XML File
To make your own XML file for Windows Movie Maker, you must create a new folder called AddOnTFX in one of two places:

- Inside the Windows Movie Maker installation folder, under the folder given the name of the locale ID of the language version installed (1033 is the locale ID for English, for example). So, for example, your new folder might be in the path C:\Program Files\Movie Maker\1033\AddOnTFX. This makes your effects usable by everyone, but to create the folder in this location, you must have Administrator privileges on your computer.

- Inside the local user's settings path, at OS Path\Documents and Settings\username\Application Data\Microsoft Movie Maker\. The user always has permission to add the new folder here, but the created effects can be used only by the user logged on as username.

Windows Movie Maker checks both paths listed above, and loads all transitions and effects it finds in both locations.

Ruzz is not online. Last active: 5/8/2004 11:47:23 AM Ruzz
Top 100 Poster
Joined: 20 Oct 2003
Total Posts: 11
 
Re: my stuff
Posted: 17 Mar 2004 01:56 AM
Definitely something weird going on with zeros/Os/pasting on this board. Anyone notice that the last effect - the one I'd re-pasted AND fixed still ended up with a letter O replacing a 0?
Rob is not online. Last active: 9/15/2017 4:38:19 PM Rob
www.windowsmoviemakers.net
Top 25 Poster
Forum Moderator
Joined: 18 Jul 2003
Total Posts: 1887
 
Re: my stuff
Posted: 17 Mar 2004 10:27 AM
Hi Ruzz,

There is a parsing problem.

When posting XML, put these tags around your code... I've added spaces below so that you can see the tag.

< code > XML CODE GOES HERE < / code >


I hope this helps, and thanks for posting =)
mr.selfdestruct is not online. Last active: 4/21/2004 2:00:08 PM mr.selfdestruct
Joined: 26 Dec 2003
Total Posts: 17
 
Re: my stuff
Posted: 17 Mar 2004 12:25 PM
*sigh*

yeah, folder is in the right place. i dunno why it wont show up in movie maker. i even put it in the local user's setting path just in case, but nothing.

Is there a way to manually make movie maker load the xml file?
Ruzz is not online. Last active: 5/8/2004 11:47:23 AM Ruzz
Top 100 Poster
Joined: 20 Oct 2003
Total Posts: 11
 
Re: my stuff
Posted: 18 Mar 2004 06:48 AM
::Is there a way to manually make movie maker load the xml file?

Not as far as I am aware. Let's go through a few things here - maybe one of these will point you toward a fix...

1 - I upgraded from MM to MM2 via a download from MS (may or may not be significant, I don't know).

2 - I edit the xml in both notepad and VS .net 2003.

3 - Notepad is saving the file as "ANSI" (not unicode).

4 - Can you open ruzz.xml in IE? It should render the default xml tree fine. If it doesn't... something was amiss with your original copy-paste-save. Somewhere on the MS documentation page (link provided earlier) it mentions a bad xml file will simply be ignored.

5 - I'm running MSXML2 v3 and v4 (depending which machine I'm at) - although, I imagine MM2 reads the xml raw so I don't suspect msxml versions are an issue - but you never know. You could try going to this page - it usually is able to "sniff out" what XML libs are installed on your machine.

Is it loading ok for everyone else?

rz


mr.selfdestruct is not online. Last active: 4/21/2004 2:00:08 PM mr.selfdestruct
Joined: 26 Dec 2003
Total Posts: 17
 
Re: my stuff
Posted: 18 Mar 2004 02:47 PM
Thanks for the help ruzz.

1. MM2 was an upgrade off MS for me as well.

2. I edited the xml in notepad, i dont know what VS .net 2003.

3. I dont know how to find out if notepad is saving as ANSI.

4. It opens up fine as an xml tree in IE.

5. I clicked the link and got a huge xml tree, was i supposed to get that?
Ruzz is not online. Last active: 5/8/2004 11:47:23 AM Ruzz
Top 100 Poster
Joined: 20 Oct 2003
Total Posts: 11
 
Re: my stuff
Posted: 18 Mar 2004 03:41 PM
::3. I dont know how to find out if notepad is saving as ANSI.

When you save a file in (modern versions of) notepad it will offer a dropdown list at bottom titled "Encoding". It shouldn't really matter for xml text, but I'm ruling nothing out (this is good old MS software running on MS operating systems after all - bound to be problematic!)

::4. It opens up fine as an xml tree in IE.
::5. I clicked the link and got a huge xml tree, was i supposed to get that?

Well, that kinda proves the file is legit. No reason why MM2 should be choosing to ignore it.

You should go to the bayes site (link in previous post). See if he can read your xml setup correctly. If there's anything "odd", fix it.

Other than that, I'm all out of ideas. Can anyone else think of something?

rz

Rehan is not online. Last active: 5/8/2012 5:49:17 PM Rehan
www.rehanfx.org
Top 25 Poster
Joined: 21 Apr 2004
Total Posts: 2176
 
Re: my stuff
Posted: 21 Apr 2004 11:28 AM
I think I have figured out whats wrong...

I had the same problem when I placed the ruzz.xml file in the 1033\AddOnTFX folder. Nothing happened. However when I moved the AddOnTFX folder (with the ruzz.xml file) to another folder C:\Program Files\Movie Maker\MUI\0409, it worked. I am guessing the 0409 folder is for the "International English" or "British English" or something similar. This folder discepancy might have been caused since I installed beta version of WMM2... etc.

Hope this helps.




www.rehanfx.org - do more with Windows Movie Maker...
rehanfx.x10hosting.com - mirror site
mr.selfdestruct is not online. Last active: 4/21/2004 2:00:08 PM mr.selfdestruct
Joined: 26 Dec 2003
Total Posts: 17
 
Re: my stuff
Posted: 21 Apr 2004 01:54 PM
nothing wrong with the xml file, put it in every folder that was recommended, and still nothing.

=(

oh well, i give up on it, thanks for the help guys.
mr.selfdestruct is not online. Last active: 4/21/2004 2:00:08 PM mr.selfdestruct
Joined: 26 Dec 2003
Total Posts: 17
 
Re: my stuff
Posted: 21 Apr 2004 02:00 PM
ha.

ok scratch that.

i just put it in the shared folder instead

c:/program files/movie maker/shared

and it worked.

go figure.
willbueche is not online. Last active: 5/2/2004 11:43:49 AM willbueche
Joined: 02 May 2004
Total Posts: 1
 
Re: my stuff
Posted: 02 May 2004 11:36 AM
A big, big thank you to Ruzz.

Not only have you dramatically expanded the number of effects available for WMM, your scripts have basically opened the door for easy customization by people like myself who don't know enough to write wholly new scripts, but who know enough to tinker!

I've just succesfully made some "add noise" effects based on your various Old Film effects. Previously I'd tried to write these without anything to base them on and failed.

So thank you thank you thank you, and please keep on.



On an odd note, does it seem that whatever formula WMM uses to zoom in or zoom out an image is not particularly good? I'd have thought that zooming out (creating a window boxed effect with black all around) would have increased the apparent quality of the image, and yet it actually seems blockier?
PapaJohn is not online. Last active: 2/23/2015 2:43:58 PM PapaJohn
www.papajohn.org
Top 25 Poster
Forum Moderator
Joined: 07 Aug 2003
Total Posts: 13291
 
Re: my stuff
Posted: 02 May 2004 12:44 PM
Ruzz, thanks for all your notes... I'm going to add a couple links to this thread on my website instead of copying the info to it. The links will go to the Editing > Video > Transitions and Effects pages.

... my website isn't here... it's at www.papajohn.org
Streety is not online. Last active: 7/30/2006 7:09:56 AM Streety
Joined: 26 Jun 2004
Total Posts: 26
 
Re: my stuff
Posted: 27 Jun 2004 08:25 AM
Can you upload an xml file easily? It's just I'm not sure what to do with the errors in the code and o's to 0's problem plus I'm sure alot of other people will find it easier.

A video I made with some unicycling tricks in it:
http://www.youtube.com/watch?v=V9ceWECb1Nc
davo75 is not online. Last active: 10/11/2006 9:34:03 PM davo75
Joined: 13 Dec 2004
Total Posts: 57
 
Re: my stuff
Posted: 15 Dec 2004 10:10 AM
hi ruzz.........nice things you got there,,i wish i could sahre mine but i havent got a clue...
but yeah they are great and work fine on mine.......apart from the foggy edge thingy ones...nothing seems to happen to the image........can ya help me?
thanks alot for your time..
Serenity is not online. Last active: 9/4/2006 2:23:55 PM Serenity
Joined: 20 Jul 2006
Total Posts: 21
 
Re: my stuff
Posted: 21 Jul 2006 05:15 PM
yea the foggy edges dunt seem to work for me either and thats one of them that i wanted the most...other than that the effects are splendid good job Ruzz...also the RT-move left and RT-move right just show a black screen...is that supposed to happen??
Chicken993 is not online. Last active: 3/16/2008 11:07:08 AM Chicken993
Joined: 08 Jul 2007
Total Posts: 37
 
Re: my stuff
Posted: 20 Sep 2007 06:24 PM
move left and right dont work. But these are totally awesome!!!
fishycomics is not online. Last active: 8/3/2016 1:46:49 PM fishycomics
Top 25 Poster
Joined: 31 Jul 2005
Total Posts: 7305
 
Re: my stuff
Posted: 20 Sep 2007 06:44 PM
here is an xml of the posted one WOW great work

34 great ones
http://www.megaupload.com/?d=2RZXKAJH



ALL YOUR XMLS IN THIS LINK===> tranistions and effects in alphabetical order <===All your XMLS IN THIS LINK!
.
.


thank you in advance If I never say
dickmr is not online. Last active: 3/26/2017 11:43:26 PM dickmr
Top 25 Poster
Joined: 10 Oct 2005
Total Posts: 3100
 
Re: my stuff
Posted: 22 Sep 2007 01:08 AM
Chicken993....note Ruzz's second post on 3/16....it corrects the 'move' xmls...he says to copy and paste that code over the originals...be certain you have the last three lines. The move ones are my favorites because you can combine to some great effect with certain transitions. Have fun!
bradyproductions is not online. Last active: 7/28/2009 4:58:17 AM bradyproductions
Top 100 Poster
Joined: 05 Mar 2007
Total Posts: 199
 
Re: my stuff
Posted: 06 Oct 2008 03:29 AM
sorry does anyone actually have this typed up without errors?
dickmr is not online. Last active: 3/26/2017 11:43:26 PM dickmr
Top 25 Poster
Joined: 10 Oct 2005
Total Posts: 3100
 
Re: my stuff
Posted: 06 Oct 2008 06:22 PM
On the megaupload link fishy has above you can get it. Enter the three letters where it says here: and click on the download button just to the right. Wait for the timer to count down on the free download and then download the zip file. Unzip it in your AddOnTFX folder and you'll have them. Have fun.
Previous Thread :: Next Thread 
Page 1 of 2Goto to page: [1], 2 Next
 
Movie Maker Forums  > Movie Maker Users Showcase  > Share Your XP Transitions and Effects!!  > my stuff