[Lights, Camera, Action]

Home    Forums    Tutorials    Search    Books    Links 

Windows Movie Maker tips, tutorials, forums and more...



 
Windows Movie Maker Home   Search   Login   Register   Member List  
Movie Maker Users Showcase  > Share Your Vista Transitions and Effects!!  > Overlaying a logo/watermark in Windows Vista    
Previous Thread :: Next Thread 
 Author Thread: Overlaying a logo/watermark in Windows Vista
considerate_guy is not online. Last active: 8/7/2015 5:49:08 PM considerate_guy
movies.blainesville.com
Top 25 Poster
Forum Moderator
Joined: 23 Mar 2005
Total Posts: 24219
 
Overlaying a logo/watermark in Windows Vista
Posted: 09 Jul 2007 07:56 PM
This was posted previously in the Windows XP thread, but I figured it was worth reposting in its own thread. If you are looking to add a logo to your video, you can do it as a custom title. All you need is an image. The best choice is an image in .png or .gif formats because they allow for transparency. Other formats will show a solid background. The following example assumes your picture is called "OverlayLogo.png".

Copy and paste the following code into Notepad and save it in your Documents folder with the name OverlayLogo.xml. Next go to C:\Program Files\Movie Maker\Shared. You will need to create an AddOnTFX folder here. Next copy logo image (OverlayLogo.png) and the .xml file (OverlayLogo.xml) to the AddOnTFX folder.

<TransitionsAndEffects Version="2.8">
<Titles>
<TitleDLL guid="TFX">
<Title name="Overlay, Logo/Watermark" guid="Blaine's Logo/Watermark Overlay" iconid="13" comment="Blaine Logo Post 126996">
<Param name="Animation" value="TitleStandard"/>
<Param name="Description" value="Places transparent logo in lower right corner"/>
<Param name="LogoBitmapFilename" value="AddOnTFX/OverlayLogo.png"/>
<Param name="LogoRect" value="0.8 0.75 0.15 0.2"/>
<Paragraph>
<Param name="IsOneLine" value="true"/>
<Param name="BoundingRect" value="0.1 0.8 0.6 0.1"/>
<Param name="MaxCharacterCount" value="32"/>
</Paragraph>
</Title>
</TitleDLL>
</Titles>
</TransitionsAndEffects>


And as always, you need to restart Movie Maker before you will see this new title. To use it, go to Tools > Titles and Credits. Choose to place the title on the selected clip. Choose "Overlay, Logo/Watermark" for the animation. If you want text, type it in, otherwise type a space. After you click 'Done' it will appear on your video. You'll probably need to go to the 'Title Overlay' track to extend the duration of the title so it lasts for as long as you need it.

Troubleshooting: If you don't see your logo (e.g. see black instead) it means you didn't correctly place your image in the AddOnTFX folder or the name doesn't match the one listed in the XML. If you don't see the animation at all, it means you didn't correctly save the .xml file in the AddOnTFX folder.

Blaine
Movie Maker (Custom Titles, Effects. etc.)Cool
WMM 6.0 on Windows 7 or 8
YouTube videos
mooser is not online. Last active: 8/7/2007 5:31:50 PM mooser
Joined: 07 Aug 2007
Total Posts: 2
 
Re: Overlaying a logo/watermark in Windows Vista
Posted: 07 Aug 2007 12:30 PM
I have tried to do this repeatedly in Windows Vista Movie Maker but whenever I go to add the watermark in Titles/Credits (how I would in the XP version of Movie Maker), my watermark turns out very small and not proportionate at all.

Are there any values I have to tinker with to make this work? Or settings in Movie Maker? I have been toying around with it for a while now and I'm stumped.
considerate_guy is not online. Last active: 8/7/2015 5:49:08 PM considerate_guy
movies.blainesville.com
Top 25 Poster
Forum Moderator
Joined: 23 Mar 2005
Total Posts: 24219
 
Re: Overlaying a logo/watermark in Windows Vista
Posted: 07 Aug 2007 12:45 PM
The size is driven by the LogoRect parameters. The first two values are the horizontal and vertical offsets from the upper left. The next two are the size. All are in relationship to 1.00 (full width or height). The example above is geared toward a square logo and it makes it 15% of the width (0.15 x 640 = 96 pixels) and 20% of the height (0.20 x 480 = 96 pixels).

If you post your logo size and where you want it to appear (center, lower right, top center, etc.), I could help you with the exact values.

Blaine
Movie Maker (Custom Titles, Effects. etc.)Cool
WMM 6.0 on Windows 7 or 8
YouTube videos
mooser is not online. Last active: 8/7/2007 5:31:50 PM mooser
Joined: 07 Aug 2007
Total Posts: 2
 
Re: Overlaying a logo/watermark in Windows Vista
Posted: 07 Aug 2007 05:18 PM
Thank you so much, you were such a big help :)
Radioscott is not online. Last active: 9/24/2007 4:33:12 PM Radioscott
www.sacksofwetcement.com
Joined: 24 Sep 2007
Total Posts: 2
 
Re: Overlaying a logo/watermark in Windows Vista
Posted: 24 Sep 2007 02:16 PM
I just can't get this to show up in my list of animations. Reading your last sentence, I assume I didn't correctly save the .xml file, but I don't know what I did wrong.

Can I get some help troubleshooting this? I don't know anything about XML, so I merely copied the code per the directions.

I'm using XP, but I figured that the procedure would be the same. Maybe that's my problem?
considerate_guy is not online. Last active: 8/7/2015 5:49:08 PM considerate_guy
movies.blainesville.com
Top 25 Poster
Forum Moderator
Joined: 23 Mar 2005
Total Posts: 24219
 
Re: Overlaying a logo/watermark in Windows Vista
Posted: 24 Sep 2007 03:47 PM
Actually, the XML is different in XP and Vista... you can tell by the starting line (version 1.0 = XP code, version 2.8 = Vista code). I also color my XML in blue for XP and purple for Vista.

You just need to find the code for XP... I'd search in the other forum (view forum 28) specifically in the alphabetical post (view post 74030).

Blaine
Movie Maker (Custom Titles, Effects. etc.)Cool
WMM 6.0 on Windows 7 or 8
YouTube videos
Radioscott is not online. Last active: 9/24/2007 4:33:12 PM Radioscott
www.sacksofwetcement.com
Joined: 24 Sep 2007
Total Posts: 2
 
Re: Overlaying a logo/watermark in Windows Vista
Posted: 24 Sep 2007 04:21 PM
Thanks! I didn't know that XML was different like that!

I found a method that worked for me here:

http://www.windowsmoviemakers.net/Forums/ShowPost.aspx?PostID=12624

Thanks again!
considerate_guy is not online. Last active: 8/7/2015 5:49:08 PM considerate_guy
movies.blainesville.com
Top 25 Poster
Forum Moderator
Joined: 23 Mar 2005
Total Posts: 24219
 
Re: Overlaying a logo/watermark in Windows Vista
Posted: 24 Sep 2007 04:23 PM
If you compare the two XML files, you'll see that there are similarities (especially when talking about titles). But Vista is a "whole new kettle of fish" and unfortunately the two are not interchangeable when it comes to custom titles, effects and transitions.

Blaine
Movie Maker (Custom Titles, Effects. etc.)Cool
WMM 6.0 on Windows 7 or 8
YouTube videos
wakefun is not online. Last active: 2/11/2008 8:43:04 PM wakefun
Joined: 08 Feb 2008
Total Posts: 5
 
Re: Overlaying a logo/watermark in Windows Vista
Posted: 08 Feb 2008 11:49 AM
I tried doing your overlay. NO luck... double checked the code... picture name... everything with no luck. I am using Vista with movie maker 6.0... any ideas?

All I get is a flashing gittery black video where the overlay is.
considerate_guy is not online. Last active: 8/7/2015 5:49:08 PM considerate_guy
movies.blainesville.com
Top 25 Poster
Forum Moderator
Joined: 23 Mar 2005
Total Posts: 24219
 
Re: Overlaying a logo/watermark in Windows Vista
Posted: 08 Feb 2008 01:59 PM
Interesting... so you see the title as an option and can pick it, but it you get glittery black instead of the image?

Can you put your image somewhere like imageshack.us and copy the link here? Also, are you using any incompatible video file types like Divx, XviD, etc. because these can sometimes cause problems. Try a test with the Sample Video clips of the butterfly or the bear and see if you get different results.

Blaine
Movie Maker (Custom Titles, Effects. etc.)Cool
WMM 6.0 on Windows 7 or 8
YouTube videos
wakefun is not online. Last active: 2/11/2008 8:43:04 PM wakefun
Joined: 08 Feb 2008
Total Posts: 5
 
Re: Overlaying a logo/watermark in Windows Vista
Posted: 08 Feb 2008 04:51 PM
I am using the sample video that comes with Microsoft... it is a .wmv of a bear in a stream. Just for testing... normal format.

The image I am using is a transparent .png file... -
here is the image

This is the code I am using -

<TransitionsAndEffects Version="2.8">
<Titles>
<TitleDLL guid="TFX">
<Title name="Overlay, Logo/Watermark" guid="Blaine's Logo/Watermark Overlay" iconid="13" comment="Blaine Logo Post 126996">
<Param name="Animation" value="TitleStandard" />
<Param name="Description" value="Places transparent logo in lower right corner" />
<Param name="LogoBitmapFilename" value="AddOnTFX/OverlayLogo.png" />
<Param name="LogoRect" value="0.8 0.75 0.15 0.2" />
<Paragraph>
<Param name="IsOneLine" value="true" />
<Param name="BoundingRect" value="0.1 0.8 0.6 0.1" />
<Param name="MaxCharacterCount" value="32" />
</Paragraph>
</Title>
</TitleDLL>
</Titles>
</TransitionsAndEffects>

Thanks!

Russ
Http://www.GadgetKing.com
considerate_guy is not online. Last active: 8/7/2015 5:49:08 PM considerate_guy
movies.blainesville.com
Top 25 Poster
Forum Moderator
Joined: 23 Mar 2005
Total Posts: 24219
 
Re: Overlaying a logo/watermark in Windows Vista
Posted: 08 Feb 2008 05:56 PM
I right-clicked and tried to download the image and it said it was of type .gif, not .png.

Try changing this line:
<Param name="LogoBitmapFilename" value="AddOnTFX/OverlayLogo.gif" />

Then also ensure that the image file in the AddOnTFX folder has exactly the same name. It usually helps to be able to see the full name with extensions, so when you open up 'Computer', click on 'Tools' > 'Folder Options'. Under 'View' uncheck the box that says 'Hide extensions of known file types'. Confirm the filename is just 'OverlayLogo.gif' and not something like 'OverlayLogo.png.gif'

Blaine
Movie Maker (Custom Titles, Effects. etc.)Cool
WMM 6.0 on Windows 7 or 8
YouTube videos
considerate_guy is not online. Last active: 8/7/2015 5:49:08 PM considerate_guy
movies.blainesville.com
Top 25 Poster
Forum Moderator
Joined: 23 Mar 2005
Total Posts: 24219
 
Re: Overlaying a logo/watermark in Windows Vista
Posted: 08 Feb 2008 06:04 PM
Now I'm confused. I just clicked again and I'm getting a different image that *is* a png file. Hmm... any more details on the type of video card you have? Have you been able to get any of my other title overlays to work?

Also, the code above is geared towards a square image placed in a 4:3 movie. The rectangular shape of the image shouldn't prevent it from appearing (other than to stretch it), but once we get this working, let's get the rectangle coordinates changed too.

Blaine
Movie Maker (Custom Titles, Effects. etc.)Cool
WMM 6.0 on Windows 7 or 8
YouTube videos
wakefun is not online. Last active: 2/11/2008 8:43:04 PM wakefun
Joined: 08 Feb 2008
Total Posts: 5
 
Re: Overlaying a logo/watermark in Windows Vista
Posted: 11 Feb 2008 11:17 AM
The image is a PNG... does google's picasa change it when it hosts it. I just checked it on my desktop and it is a PNG. The video card I am using is a XFX Nvidia GeForce 8600GT.

I am using about 3 of your other overlays to work with no problems... Just this one is giving me problems!
wakefun is not online. Last active: 2/11/2008 8:43:04 PM wakefun
Joined: 08 Feb 2008
Total Posts: 5
 
Re: Overlaying a logo/watermark in Windows Vista
Posted: 11 Feb 2008 11:21 AM
You were right... I just double checked the file name and it was OverlayLogo.png.png ... I removed one of the .png's and it works. It is distorted but working!!! Thanks a million!
considerate_guy is not online. Last active: 8/7/2015 5:49:08 PM considerate_guy
movies.blainesville.com
Top 25 Poster
Forum Moderator
Joined: 23 Mar 2005
Total Posts: 24219
 
Re: Overlaying a logo/watermark in Windows Vista
Posted: 11 Feb 2008 01:42 PM
The dimensions of your logo are 150 x 46.

Relative to a 4:3 screen (e.g. 640 x 480) this would be a size of:
150 / 640 = 0.234375 --> 0.234
46 / 480 = 0.0958333333 ---> 0.096

To better match your logo's dimensions, try changing the code as follows:

<TransitionsAndEffects Version="2.8">
<Titles>
<TitleDLL guid="TFX">
<Title name="Overlay, Logo/Watermark" guid="Blaine's Logo/Watermark Overlay" iconid="13" comment="Blaine Logo Post 126996">
<Param name="Animation" value="TitleStandard" />
<Param name="Description" value="Places transparent logo in lower right corner" />
<Param name="LogoBitmapFilename" value="AddOnTFX/OverlayLogo.png" />
<Param name="LogoRect" value="0.716 0.85 0.234 0.096" />
<Paragraph>
<Param name="IsOneLine" value="true" />
<Param name="BoundingRect" value="0.1 0.8 0.6 0.1" />
<Param name="MaxCharacterCount" value="32" />
</Paragraph>
</Title>
</TitleDLL>
</Titles>
</TransitionsAndEffects>

Blaine
Movie Maker (Custom Titles, Effects. etc.)Cool
WMM 6.0 on Windows 7 or 8
YouTube videos
wakefun is not online. Last active: 2/11/2008 8:43:04 PM wakefun
Joined: 08 Feb 2008
Total Posts: 5
 
Re: Overlaying a logo/watermark in Windows Vista
Posted: 11 Feb 2008 08:43 PM
You are the best! Worked perfectly... I just need to quit doing wide format videos... but it worked great. Have a look.

http://www.youtube.com/watch?v=8YuMcP9t7UY

Thanks,

Russ
http://www.GadgetKing.com
considerate_guy is not online. Last active: 8/7/2015 5:49:08 PM considerate_guy
movies.blainesville.com
Top 25 Poster
Forum Moderator
Joined: 23 Mar 2005
Total Posts: 24219
 
Re: Overlaying a logo/watermark in Windows Vista
Posted: 11 Feb 2008 10:11 PM
Or you could make a version that works on widescreen too! Add the lines in bold.

<TransitionsAndEffects Version="2.8">
<Titles>
<TitleDLL guid="TFX">
<Title name="Overlay, Logo/Watermark (4:3)" guid="Blaine's Logo/Watermark Overlay GK43" iconid="13" comment="Blaine Logo Post 126996">
<Param name="Animation" value="TitleStandard" />
<Param name="Description" value="Places transparent logo in lower right corner" />
<Param name="LogoBitmapFilename" value="AddOnTFX/OverlayLogo.png" />
<Param name="LogoRect" value="0.716 0.85 0.234 0.096" />
<Paragraph>
<Param name="IsOneLine" value="true" />
<Param name="BoundingRect" value="0.1 0.8 0.6 0.1" />
<Param name="MaxCharacterCount" value="32" />
</Paragraph>
</Title>
<Title name="Overlay, Logo/Watermark (16:9)" guid="Blaine's Logo/Watermark Overlay GK169" iconid="13" comment="Blaine Logo Post 126996">
<Param name="Animation" value="TitleStandard" />
<Param name="Description" value="Places transparent logo in lower right corner" />
<Param name="LogoBitmapFilename" value="AddOnTFX/OverlayLogo.png" />
<Param name="LogoRect" value="0.774 0.85 0.176 0.096" />
<Paragraph>
<Param name="IsOneLine" value="true" />
<Param name="BoundingRect" value="0.1 0.8 0.6 0.1" />
<Param name="MaxCharacterCount" value="32" />
</Paragraph>
</Title>

</TitleDLL>
</Titles>
</TransitionsAndEffects>


Blaine
Movie Maker (Custom Titles, Effects. etc.)Cool
WMM 6.0 on Windows 7 or 8
YouTube videos
axius is not online. Last active: 4/29/2008 11:30:42 AM axius
Joined: 12 Feb 2008
Total Posts: 4
 
Re: Overlaying a logo/watermark in Windows Vista
Posted: 21 Feb 2008 04:24 PM
I'm trying to make use of WMM 6's new flexible parameters with values that can change in time. For example, I want my overlay logo to move across the screen while changing size. It should be something like this:

<TransitionsAndEffects Version="2.8">
<Titles>
<TitleDLL guid="TFX">
<Title name="Moving Logo 1" guid="Moving Logo 1" iconid="13">
<Param name="Animation" value="TitleStandard"/>
<Param name="Description" value="Logo that moves and changes size"/>
<Paragraph>
<Param name="IsOneLine" value="true"/>
<Param name="MaxCharacterCount" value="16"/>
</Paragraph>
<Param name="LogoBitmapFilename" value="AddOnTFX\logo1.png"/>
<LogoRect evaluation="Linear" type="float4"/>
<Point time="0.0" value="0.0,0.0,0.2,0.2"/>
<Point time="0.5" value="0.3,0.3,0.4,0.4"/>
<Point time="1.0" value="0.8,0.8,0.2,0.2"/>
</LogoRect>
</Title>
</TitleDLL>
</Titles>
</TransitionsAndEffects>

However, this XML doesn't get accepted (the title doesn't show up in the list). It does work if the logo rectangle specified as a static value instead of the structure with 3 points:

<Param name="LogoRect" value="0.3 0.3 0.4 0.4"/>

So I guess either I'm not specifying it right or LogoRect does not support time points (despite Microsoft's claim that any Param does, http://msdn2.microsoft.com/en-us/library/bb331627(VS.85).aspx).

What am I doing wrong?
considerate_guy is not online. Last active: 8/7/2015 5:49:08 PM considerate_guy
movies.blainesville.com
Top 25 Poster
Forum Moderator
Joined: 23 Mar 2005
Total Posts: 24219
 
Re: Overlaying a logo/watermark in Windows Vista
Posted: 21 Feb 2008 06:02 PM
Ah! I see your confusion. The information Microsoft supplied was for customizing *transitions* and *effects*. They actually have never supplied the details on how to customize titles, but several resourceful people figured it out for XP. In Vista, most everything from XP carries over.

Unfortunately, since Microsoft isn't officially supporting custom titles, they didn't do any updating like they did for transitions and effects. As a result, you can't use multiple point time values for titles. You only get the stuff you could do in XP.

Wouldn't that be neat if you could though!?!?!

Blaine
Movie Maker (Custom Titles, Effects. etc.)Cool
WMM 6.0 on Windows 7 or 8
YouTube videos
peakstriker3 is not online. Last active: 6/15/2008 12:07:12 AM peakstriker3
Joined: 08 Mar 2008
Total Posts: 20
 
Re: Overlaying a logo/watermark in Windows Vista
Posted: 21 Mar 2008 11:42 AM
I know im stupid but i cant find C:\Program Files\Movie Maker\Shared
considerate_guy is not online. Last active: 8/7/2015 5:49:08 PM considerate_guy
movies.blainesville.com
Top 25 Poster
Forum Moderator
Joined: 23 Mar 2005
Total Posts: 24219
 
Re: Overlaying a logo/watermark in Windows Vista
Posted: 21 Mar 2008 01:14 PM
There could be several reasons for that:
1) You are on a 64-bit version of Movie Maker.
2) You had to downgrade to version 2.6 because your system isn't powerful enough to run WMM 6.0
3) You are running a different language version of Vista that calls 'Program Files' something different like 'Programmes'.
4) You just aren't sure where to go.

Try this:
1) Click on 'Computer'
2) Click on the C: drive
3) Click on the 'Program Files' folder
4) Scroll and find the 'Movie Maker' folder
5) Scroll and find the 'Shared' folder.

Now if you are that far, right-click, choose 'New Folder' and call it 'AddOnTFX'.

Please let us know how far you get and what exact problem you are having.

Blaine
Movie Maker (Custom Titles, Effects. etc.)Cool
WMM 6.0 on Windows 7 or 8
YouTube videos
peakstriker3 is not online. Last active: 6/15/2008 12:07:12 AM peakstriker3
Joined: 08 Mar 2008
Total Posts: 20
 
Re: Overlaying a logo/watermark in Windows Vista
Posted: 27 Mar 2008 09:41 PM
OK i did all that but when i click on the preview it just turns black.
considerate_guy is not online. Last active: 8/7/2015 5:49:08 PM considerate_guy
movies.blainesville.com
Top 25 Poster
Forum Moderator
Joined: 23 Mar 2005
Total Posts: 24219
 
Re: Overlaying a logo/watermark in Windows Vista
Posted: 28 Mar 2008 02:43 PM
Sorry, I'm not psychic. Insufficient information supplied to be able to help you.

Blaine
Movie Maker (Custom Titles, Effects. etc.)Cool
WMM 6.0 on Windows 7 or 8
YouTube videos
peakstriker3 is not online. Last active: 6/15/2008 12:07:12 AM peakstriker3
Joined: 08 Mar 2008
Total Posts: 20
 
Re: Overlaying a logo/watermark in Windows Vista
Posted: 05 Apr 2008 01:03 AM
Is there just a download because this is too hard for me.
Previous Thread :: Next Thread 
Page 1 of 5Goto to page: [1], 2, 3, 4, 5 Next
 
Movie Maker Forums  > Movie Maker Users Showcase  > Share Your Vista Transitions and Effects!!  > Overlaying a logo/watermark in Windows Vista